quarta-feira, 25 de julho de 2018

Como criar PDF/A no LibreOffice

Se você é advogado e atua na Justiça do Trabalho, ao peticionar eletronicamente, provavelmente já se deparou com a exigência de que suas petições devem estar no formato PDF e no padrão ISO-19005 (PDF/A), nos termos da Resolução CSTJ n° 185/2017 (disponível aqui, a quem se interessar).

Fica então a dica de como criar esse tipo de arquivo (PDF/A) no LibreOffice, editor de texto livre e gratuito, equivalente ao Word.

Se você costuma usar o botão "Criar PDF", localizado no painel, entre os botões de "Salvar" e "Imprimir", apesar de ser muito prático, saiba que ele cria um PDF em um formato que não é o estabelecido pelo padrão ISO-19005 (para mais detalhes sobre esse padrão, sugiro uma visita à PDF Association).

Vamos lá:  como criar um PDF/A no LibreOffice Writer (editor de texto):

Com o documento/texto pronto, clique no Menu > Arquivo > Exportar como PDF

E, na janela que aparece, clique na opção (Geral) "Arquivo PDF/A-1a (ISO 19005), como mostrado abaixo:



Pronto, seu PDF/A está pronto e sua petição pode ser protocolada na Justiça do Trabalho.

sexta-feira, 28 de julho de 2017

quinta-feira, 9 de março de 2017

Como instalar o módulo de segurança do Banco do Brasil (e outros bancos) no Linux

O Banco do Brasil passou a exigir o módulo de segurança Warsaw.  Caso você ainda não tenha esse módulo instalado, ao tentar fazer seu login um aviso na página do BB te sugere ir para a
página https://seg.bb.com.br/home.html que, automaticamente, detecta a presença do plugin e, teoricamente, disponibiliza o executável para download, assim como um passo a passo bem completo, compreendendo Ubuntu, OpenSuse, Fedora e "outras distribuições"

O problema é que o BB não detecta corretamente as distros e, no meu caso, que uso Ubuntu 16.10, ao invés de baixar um executável .deb, acabou vindo um executável genérico .run, que não funcionou.

Analisando os links do BB, percebi que o executável estava sendo baixado do site http://www.dieboldnixdorf.com.br.  Então entrei nesse site e procurei o executável deb.  Não foi muito difícil.

Assim, a solução foi ir para a página http://www.dieboldnixdorf.com.br/warsaw e escolher a instituição financeira, esperar a verificação da presença do módulo de segurança -- que não foi
detectada -- e, em seguida, fazer o download do warsaw_setup64.deb.

Após a instalação, reinicie a máquina e você deve ter acesso novamente a sua conta no Banco do Brasil.

quarta-feira, 14 de dezembro de 2016

No more Nautilu's "make link" on Ubuntu 16.10???

I was sad & mad, because I use this feature of creating symlinks directly from nautilus contextual menu.

But I came to know that it isn't actually gone.  It's just a preference away...

All you have to do is go into Nautilus Preferences > Behavior tab and mark the "Link Creation" option.  Voilá.


Good linking!

Source: https://askubuntu.com/questions/843150/what-happened-to-the-create-link-feature-in-nautilus-in-ubuntu-16-10/843165#843165?newreg=ac543d681b9f496eb4ed49bc6bd563d9

terça-feira, 11 de outubro de 2016

Annoyed with "Chrome didn't shut down correctly" on your Linux?

One simple solution:

1.  Open Chrome's menu, by clicking on the 3 dots (left-up corner):




2. On the opening drawer, click on "Settings"


(The settings page will open)



3. Scroll all the way down and select "Show advanced settings..."

(More options will appear)


4. Scroll all the way down again and under "Systems", unmark the option shown below:


Voilá.  You should be fine and hopefully Chrome will not insist on not having shut down correctly in the future.

Search: Chrome didn't shut down correctly

terça-feira, 10 de maio de 2016

Teclas / (barra) e ? (interrogação) no Lenovo ThinkPad T440p

Usando o Ubuntu 16.04 em um ThinkPad T440p que comprei de segunda mão, percebi que a tecla da barra (/) e interrogação (?) não estavam funcionando.  Em algum lugar na Internet descobri que se podia usar o atalho AltGr + q para a barra e AltGr + w para a interrogação, mas não era exatamente prático.

Pesquisando mais um pouco, vi que a própria Lenovo tinha disponibilizado um arquivo (disponível nesse link) para solucionar esse problema mas que obviamente funciona apenas no Windows.

A solução para quem usa Linux veio através do botecodigital e reproduzo abaixo:

1. O primeiro passo é instalar o x11-xserver-utils via o comando abaixo:
(no meu ubuntu, já estava instalado)

sudo apt-get install x11-xserver-utils

2. O segundo passo é, em um terminal, usar o seguinte comando para mapear a tecla

xmodmap -e "keycode 105 = KP_Divide question"

3. Se tudo correu bem e a tecla funcionou, basta colocar o comando acima na inicialização do linux:


4. Caso contrário, para saber qual keycode corresponde à tecla inativa no seu teclado (e alterar o comando adequadamente), use o comando abaixo:

xev | grep -A2 --line-buffered '^KeyRelease' | sed -n '/keycode /s/^.*keycode \([0-9]*\).* (.*, \(.*\)).*$/\1 \2/p'

sexta-feira, 11 de março de 2016

Solucionar erro no repositório do google-chrome [ubuntu]

Se você vem recebendo avisos de erro ao realizar as atualizações no Ubuntu e derivados (ou aquele triângulo vermelho na barra superior), é provavelmente devido ao fim do suporte do google-chrome para as arquiteturas i386.

A solução, como indicado pelo OMG Ubuntu, é editar a linha do repositório para especificar a arquitetura x64, como mostrado abaixo:

1. Abra uma nova janela de Terminal e digite o seguinte comando:
sudo gedit /etc/apt/sources.list.d/google-chrome.list
2. Na janela de texto de abrirá, edite o arquivo para que ele fique desta forma:
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
A única alteração que você precisa fazer é acrescer o [amd64] após o ‘deb’ mas antes do ‘http’. Não modifique as demais partes deste arquivo.
3. Clique em salvar e feche a janela do editor (Gedit).
Agora volte ao Terminal e atualize as informações dos repositórios com o comando:
sudo apt-get update
O erro ‘failed to fetch’ não deve mais aparecer.